Unable to Run Reports — System Cannot Find the File Specified
Symptoms
- When trying to run a report via Netwrix Auditor, you encounter the following error:
An internal error occurred on the report server. See the error log for more details. (rsInternalError)
The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
- When trying to access the Report Manager via URL (specified in Netwrix Auditor Settings > Audit Database), you encounter the following error:
The service is not available.
The report server can't connect to its database. Make sure the database is running and accessible.
Cause
A report server database is missing.
Resolution
Refer to the following steps to resolve the issue:
- In your Netwrix Auditor server, disable Netwrix Auditor Archive Service and Netwrix Auditor Management Service via Services.
- Deploy the report server database — refer to the following article for in-depth instructions: Deploying the Report Server Database
- Once you've configured the report server database, grant the roles to the SSRS service account the roles required. Refer to the following article for additional information: Configure SSRS account and How to Assign db_owner Permissions
- Restart Netwrix Auditor Archive Service and Netwrix Auditor Management Service on your Netwrix Auditor server via Services.