No Monitoring Plans Found in Netwrix Auditor
Symptom
When attempting to view a report, the Monitoring Plan dropdown list reads as follows:
NO MONITORING PLANS FOUND
![Monitoring Plan dropdown showing NO MONITORING PLANS FOUND]./../0-images/ka04u00000117TM_0EM4u000008M6Wx.png)
Causes
- A data source type for the report you're viewing is not added to any of your existing monitoring plans.
- E.g., if you're generating a File Servers report, it won't be generated unless you have at least one monitoring plan for a File Servers data source.
- A monitoring plan for the data source type exists, but no data has been collected, or uploaded to your SQL Server instance databases.
- You're attempting to view a report under the State-in-Time category, while data collection for State-in-Time reports for the data source is disabled.
- The Reports folder is corrupted.
Resolutions
-
Create a new monitoring plan for the data source. Refer to the following article for additional information: Monitoring Plans
-
Review the corresponding data source settings:
- Review your Health Log for errors related to the monitoring plan containing the data source.
- Review the monitoring plan settings:
- In the main Netwrix Auditor menu, click Monitoring Plans.
- In the left pane, select the appropriate monitoring plan and click Edit.
- In the right pane, click Edit settings under the Monitoring plan section.
- Review the Data Collection tab for correct data collection account credentials.
- Review the Audit Database tab for correct database specified, as well as credentials.
- Make sure the Audit Database tab has the Disable security intelligence and make data available only in activity summaries checkbox unchecked.
- Save the changes.
-
Review the data source with State-in-Time reporting:
- In the main Netwrix Auditor menu, click Monitoring Plans.
- In the left pane, select the appropriate monitoring plan and click Edit.
- In the right pane, click Edit data source under the Data source section.
- Review the General tab to switch the Collect data for state-in-time reports switch on.
- Save the changes.
NOTE: Once data is collected (once every 24 hours by default), it should become available in the report.
- Recreate the Reports folder.
- In elevated PowerShell, execute the following command to stop the corresponding service:
Stop-Service -DisplayName "Netwrix Auditor Management Service" - Open Report Manager in your browser.
- You can find the Report Manager URL in your main Netwrix Auditor menu > Settings > Audit Database tab > Report Manager URL.
- In the main SQL Server Reporting Services window, locate the Netwrix Auditor folder.
- Click the meatball ⸱⸱⸱ button, and select Delete.
- Follow the path provided:
C:\ProgramData\Netwrix Auditor\Reports - Delete the contents of the Reports folder.
- Once deleted, follow the path provided to find the Reports.zip archive in the root of the folder:
C:\ProgramData\Netwrix Auditor - Extract the contents of the Reports.zip archive to the
C:\ProgramData\Netwrix Auditor\Reportsfolder. - In elevated PowerShell, execute the following command to start the corresponding service:
Start-Service -DisplayName "Netwrix Auditor Management Service" - Wait for about 10 minutes for reports to upload to your Report Manager. You can track the progress by following the Report Manager URL and entering the Netwrix Auditor folder.
- Once the affected report is uploaded, run the report again.
- In elevated PowerShell, execute the following command to stop the corresponding service:
IMPORTANT: There are downsides to this approach:
- The account specified in Audit database settings for Report Server should have local admin permissions, as well as permissions to create folders, and upload folders.
- Any folder/report access permissions set up in Report Manager directly instead of monitoring plans delegation will have to be reconfigured. Alternatively, you can delete a particular affected report instead of deleting the entire Netwrix Auditor reports folder.
- In case you've previously added a custom report, you will have to manually set it up again. This could apply to the report provided in the following article: How to Monitor Print Service Activity.