SSRS TempDB Permanently Grows Large and Occupies Disk Space
Symptom
The temporary SSRS database (TempDB) in your environment permanently grows large when you run reports or investigations.
Cause
The SQL Server service account has insufficient permissions to clear the TempDB.
Resolution
NOTE: To establish the SQL Server service account, click Settings in the main Netwrix Auditor menu > Audit Database > User name.
Grant the db_owner role to the SQL Server service account.
- Run Microsoft SQL Server Management Studio and connect to the SQL instance.
- In Object Explorer, proceed to Security > Logins > right-click the affected SQL Server service account > Properties.
- In the User Mapping tab, locate the TempDB, highlight it and review the roles assigned to the affected account in the Database role membership window.
- Check the
db_ownercheckbox and click OK to save changes.
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