Error: An Item with the Same Key Has Already Been Added
Symptoms
The Overview dashboard shows data, but when you drill down to a report, it says no data found.
When you try to upload a State-in-Time snapshot manually, the following error appears:
Cannot apply changes.
Error saving the Active Directory state-in-time snapshot to Audit Database: An item with the same key has already been added.
Cause
There are duplicated items in the monitored environment which led to "mangled" entries.
It is not the only possible root cause, but it is becoming increasingly more common, especially in customer environments with several organizations within Active Directory or hybridized environments.
Resolution
Review the following Microsoft article that describes how these "mangled" entries are handled by the system, how to find them, and how to fix the duplicates: https://learn.microsoft.com/en-us/archive/technet-wiki/15435.active-directory-duplicate-object-name-resolution (Active Directory: Duplicate Object Name Resolution ⸱ Microsoft 🤝).