Error: Service Did Not Respond to Start or Control Request in SSRS
Symptoms
The following symptoms affect your Netwrix Auditor and SQL Server Reporting Services (SSRS) server:
- When you attempt to run reports via the Auditor console, you see the following message:
Can't reach this page.
- The
SQL Server Reporting Servicesservice fails to start and displays error 1053:
Error 1053: The service did not respond to the start or control request in a timely fashion.
- The SSRS log files located in
C:\Program Files\Microsoft SQL Server Reporting Services\SSRS\LogFilescontain the following error:
System.IO.FileLoadException: Could not load file or assembly '%name%' or one of its dependencies.
The located assembly's manifest definition does not match the assembly reference.
(Exception from HRESULT: 0x80131040)
Cause
Your SSRS instance is corrupted.
NOTE: In some cases of SSRS corruption, the following SSRS files are blank or contain illegible symbols:
C:\Program Files\Microsoft SQL Server Reporting Services\SSRS\ReportServer\web.configC:\Program Files\Microsoft SQL Server Reporting Services\SSRS\ReportServer\rssrvpolicy.configC:\Program Files\Microsoft SQL Server Reporting Services\SSRS\Portal\RSPortal.exe.config
Resolutions
Apply one of the following options to resolve the issue:
-
Repair the SSRS instance.
- In Programs and Features, select Microsoft SQL Server Reporting Services and click Uninstall/Change.
- In the new window, select Repair and proceed with the prompted steps.
-
Uninstall SQL Server Reporting Services and install the application on the Auditor server.
IMPORTANT: This resolution applies only to SQL Server Standard and Enterprise editions.