Skip to main content

Error: The Remote Procedure Call Failed

Symptom

You see the following error in Health Log for a monitoring plan:

Event ID:5004
Data collection has failed. Error: The remote procedure call failed.

Cause

The "Remote procedure call failed" error can have a number of root causes such as a closed port, Antivirus or EDR software, resource availability on the target system, etc.

Resolution

Depending on the error cause, follow the resolution steps below:

  1. Make sure you have all required ports opened. For additional information on configuring ports for Netwrix Auditor, refer to the following article: Protocols and Ports Required
  2. Review your Antivirus exclusions. For additional information on required exclusions for your antivirus, refer to the following article: Antivirus Exclusions for Netwrix Auditor
  3. If the issue occurs during Logon Activity data collection, try to follow the steps in these articles: