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The Remote Procedure Call Failed Error When Collecting Logs

Symptom

When trying to collect data from target systems with Netwrix Auditor, the following error appears:

The remote procedure call failed and did not execute.

Causes

Here are the possible causes for the issue:

  • Cause 1. Current Firewall configuration blocks access to event logs.
  • Cause 2. Insufficient permissions for the account used for data collection.
  • Cause 3. Issues with RPC server (RPC server is unavailable).

Resolutions

Review the possible resolutions depending on you cause:

  • For cause 1. Make sure you configured Firewall rules. For additional information on the Firewall rules configuration, refer to the following article: Protocols and Ports Required

  • For cause 2. Make sure you assigned all required rights and permissions to the account used for data collection. For additional information on the data collecting account configuration, refer to the following article: Data Collecting Account

  • For cause 3. For additional information on the data collecting account configuration, refer to the following article: Error 0x800706BA − RPC Server Is Unavailable