Automatic user enrollment failed: Server certificate revocation check failed
You see the following error when the enrollment wizard starts:
Automatic user enrollment failed: Server certificate revocation check failed. (Error Code:12057, URL: https://pmserver/gina_isprofilecreated.asp) Please contact your system administrator if this problem persists.
Cause
The error means that the system was not able to check if the SSL certificate was revoked. In case of third-party certificates, it can be caused by firewall or anti-malware software blocking connections to revocation servers. Self-signed certificates are usually not checked for revocation, however the reason for the issue might be the same - the system cannot reach any certificate authority.
Resolution
To address the issue:
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Make sure firewall or other software is not blocking connection. Enable all connections and launch the wizard.
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Also make sure that proxy server is not affecting connection.
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If you use a self-signed certificate - try disabling the proxy and launch the wizard.
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If the above does not work try disabling revocation check:
- Open Control Panel → Internet Options.
- Go to the Advanced tab.
- Under the Security group of settings, disable the Check server certificate for revocation checkbox.