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Error: Request for Downloading Published Reports Failed

Symptoms

Either of the following symptoms is present in your environment:

  • Upon opening the Reporting web page, you receive the following error:
! Request for downloading published reports failed: Internal Server Error

Error message indicating 'Request for downloading published reports failed: Internal Server Error'

  • If the file is corrupted, the following error could appear when opening the Netwrix Access Analyzer console.

Console pop-up showing the error message 'Hexadecimal value 0x00, is an invalid character.'

  • Log entry example:
DEBUG Netwrix Enterprise Auditor IsGroupPublished "Data at the root level is invalid. Line 1, position 1."
%sainstalldir%\SADatabase\Logs\Application\SADebug-20250306124900-10776.TSV

Cause

The issue is caused by a corrupted Reports.xml.

Resolution

To resolve these errors, follow the steps below.

  1. Rebuild the Reports folder under the install path. If you want to back up the folder, archive it prior to deleting the original.

    NOTE: To find the install path, enter the following environmental variable into the application server's Windows File Explorer: %sainstalldir%. Then, right-click the Reports folder to archive and/or delete it.

  2. Close and reopen the Access Analyzer Console to rebuild the folder.

  3. To publish the report(s) again, right-click a needed Job Group (for example, Jobs), and select Publish to publish the reports from the selected job group or job without regenerating the report.

Publishing from a job group in Access Analyzer

  1. Select Publish Reports and click Next.

Navigation and publishing actions in Access Analyzer

  1. Select objects as needed. Then, click Next to run the report.

Selecting objects to publish

  1. Once the report has run successfully, click Finish to close out of the Reporting web page.

Finish publishing reports

NOTE: Additionally, reports will be rebuilt when the related job completes its next run.