Rolling-Log Fix: "AgentTaskRunner - Task Execution Failed for Task 11 - TrackerPollTask-Baseline-processtracker-88"
This article explains how to clear the following error from the Rolling Log in Netwrix Change Tracker.
Symptom
The following error appears in the agent Rolling Log:
2018-04-10 10:56:26,887 [7] ERROR AgentTaskRunner - task execution failed for task 11 - TrackerPollTask-Baseline-processtracker-88
NNT.Agent.Tracking.TrackerException: no data collector registered for: processtracker-local
at NNT.Agent.Core.Tracking.TrackerBase.GetDataCollector (System.String collectorName, System.Boolean throwException) [0x0002e] in :0
at NNT.Agent.Core.Tracking.TrackerBase.PollInternal (NNT.Agent.Core.Tracking.PollControl pollControl, NNT.Agent.Core.Interfaces.IDevice device, NNT.Agent.Core.Interfaces.ITrackerConfiguration
configuration, NNT.Agent.Core.Interfaces.IItemStoragePipeline queue, NNT.Agent.Core.Tracking.PollType pollType, System.DateTime pollStartTimeUtc) [0x0004c] in:0
at NNT.Agent.Core.Tracking.TrackerBase.Poll (NNT.Agent.Core.Tracking.PollControl pollControl, NNT.Agent.Core.Interfaces.IDevice device, NNT.Agent.Core.Interfaces.IItemStoragePipeline queue,
NNT.Agent.Core.Tracking.PollType pollType, System.DateTime pollStartTimeUtc) [0x00075] in :0
at NNT.Agent.Core.Tasks.TrackerPollTask.Execute (NNT.Agent.Core.Queue.AgentTaskQueue queueContext) [0x00279] in :0
at NNT.Agent.Core.Application.AgentTaskRunner.ExecuteTask (System.Int32 runnerId, NNT.Agent.Core.Interfaces.IAgentTask task, System.DateTime nowUtc, NNT.Agent.Core.Queue.AgentTaskQueue queue)
[0x00050] in :0
Cause
This error occurs because the process tracker in Netwrix Change Tracker is enabled in the policy template, but no specific processes are configured for tracking. The agent cannot execute the tracker poll task without at least one process defined.
Resolution
Edit the policy template assigned to the affected device(s) and either add processes to track or disable the process tracker.
- Log into Netwrix Change Tracker
- Navigate to Devices
- Select the device experiencing the error
- Select the policy template that is causing the issue (devices can have multiple templatesd assigned, so select the template(s) where the "Processess and Services" tracker is enabled)
- Select "Processess and Services" tracker
- To resolve the issue: 6a. Uncheck the Track processes and services in this template box OR 6b. Add at least one service to be tracked.
6a Exmaple
6b Exmaple