Old or Duplicate Events Reported as New in Syslogs
This article explains why old or duplicate events may appear as new in syslogs and how to resolve the issue by clearing the pending notifications queue in MongoDB.
Symptom
- Old events appear in syslogs as new events. Upon further investigation, these are confirmed to be duplicates of previously reported events.
- The affected events have not been resubmitted.
Cause
The pending notifications queue in the MongoDB database contains notifications for older events. When the outdated notifications are released, they are reported as new events or duplicates of previously reported events.
Resolution
-
Download the MongoDB Shell
.zipfrom the MongoDB Shell download page and place the contents intoC:\Program Files\NNT Change Tracker Suite\Gen7\MongoDB\bin. -
Once copied, run the
mongosh.exeapplication to connect to your MongoDB database. Run the following command:mongodb://localhost:27017NOTE: Replace
27017with the correct port if MongoDB in your environment uses a different port. -
Once connected to your MongoDB database, run the following commands to confirm whether notifications are queued:
use NNTHubServicedb.IncomingEventQueue.countDocuments()db.NotificationQueue.countDocuments()db.PendingNotifications.countDocuments()db.BackgroundTaskQueue.countDocuments() -
To clean up the queued notifications, run the following commands:
use NNTHubServicedb.NotificationQueue.deleteMany({})