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Rolling-Log Fix: "HubDetails - Crypto Error. Has the Agent Process Account Changed Since the Password Data Was Entered?"

This article explains how to resolve the HubDetails - Crypto error in the Netwrix Change Tracker agent Rolling Log by repairing the HubDetails.xml file.

Symptom

The following error appears in the agent Rolling Log, typically followed by additional messages indicating the application is shutting down:

2019-01-04 07:02:35,644 [4] ERROR HubDetails - Crypto error. Has the agent process account changed since the password data was entered?
System.Security.Cryptography.CryptographicException: Key not valid for use in specified state.

2019-01-04 07:02:35,675 [4] ERROR ConfigurationLoader - Hub details cannot be read successfully from: C:\ProgramData\NNT\gen7agent.app.netcore\HubDetails.xml. Error: Key not valid for use in specified state.
2019-01-04 07:02:35,675 [4] INFO Message - Application core shutting down due to error, please restart service: Hub details cannot be read successfully from: C:\ProgramData\NNT\gen7agent.app.netcore\HubDetails.xml. Error: Key not valid for use in specified state.
2019-01-04 07:02:35,691 [4] INFO Message - Application starting shutdown due to: FatalError - Hub details cannot be read successfully from: C:\ProgramData\NNT\gen7agent.app.netcore\HubDetails.xml. Error: Key not valid for use in specified state.

Cause

The information in the HubDetails.xml file cannot be decrypted by the current agent service account. Each agent must locally encrypt the password entered into the HubDetails.xml file. This error commonly occurs when copying a HubDetails.xml file from one agent to another to simplify installation — the password encrypted on the source machine cannot be decrypted on the destination machine.

Resolution

If you are receiving this error, the agent is not reporting to your hub. This is a critical error and monitoring will not continue until it is resolved.

  1. Stop the Netwrix ChangeTracker Gen7 Agent NetCore service.

    On Windows:

  2. Open Services.msc

  3. Stop the service called: Netwrix ChangeTracker Gen7 Agent NetCore

On Linux:

service nntgen7agentcore stop
  1. Navigate to the agent service data folder:

    • Windows: C:\ProgramData\NNT\gen7agent.app.netcore
    • Linux: /var/nnt/gen7agent.app.netcore/
  2. Delete all files in this folder except for the HubDetails.xml file.

  3. Edit the HubDetails.xml file using a text editor such as Notepad (Windows) or Nano (Linux).

  4. Remove the entire line containing the <E1> tags.

  5. Replace the password element with the following, substituting your actual agent password:

    <Password>Enter-Password-Here</Password>
  6. Confirm that the HubDetails.xml file contains the proper information in the correct format.

    For more information about the HubDetails.xml file, refer to the Agent HubDetails File documentation.

  7. Start the Netwrix ChangeTracker Gen7 Agent NetCore service.

    On Windows:

  8. Open Services.msc

  9. Start the service called: Netwrix ChangeTracker Gen7 Agent NetCore

On Linux:

service nntgen7agentcore start
  1. Check the Rolling Log to verify the agent was able to read the information and connect to the hub.
  1. You can also confirm that the device is registered and online via the Netwrix Change Tracker web console.