Error: WinHTTP Connection Terminated Abnormally
Symptom
On a Windows system, the Netwrix ChangeTracker Gen7 Agent NetCore installer produces an error during the Hub connection test, even with correct Hub credentials.
Cause
On older Windows systems, WinHTTP does not use TLS 1.1 or TLS 1.2 as a default secure protocol. If the Netwrix Change Tracker Hub requires a modern TLS version, the connection is terminated during the installer's Hub connection test.
Resolution
- Close the Netwrix ChangeTracker Gen7 Agent NetCore installer.
- Review the information provided by Microsoft for this specific issue: Enable TLS 1.1 and TLS 1.2 as default secure protocols in WinHTTP in Windows.
- Once the appropriate updates have been installed and/or changes have been made to the systems registry, as outlined by Microsoft, re-run the Netwrix ChangeTracker Gen7 Agent NetCore installer and confirm if the Hub connection test completes successfully. If the test continues to fail, choose the Do not test my hub connection before proceeding option in the installer. This will enable the agent to be installed, bypassing the connection check. If the connectivity issue persists post install, a support ticket should be opened with the Netwrix Change Tracker support team. More information/specific error logs related to the issue can be found in the
C:\ProgramData\NNT\gen7agent.app.netcore\rolling-log.txtfile, so this should be included upon opening the support ticket to help aid troubleshooting of the issue.