Unable to Upgrade SI Agents
Symptoms
- When attempting to upgrade a SI Agent, no updates are available.
- The message
You're using the latest versionis prompted while an upgrade is expected to occur.
Cause
The upgrade will fail for previous versions of SI Agents in servers without required certificates.
Resolution
Refer to the following steps to allow SI Agents to self-upgrade to future versions:
- Uninstall the previous version of installed SI Agent.
- Install the latest SI Agent.
- Install required certificates.
Install required certificates − Preparation
- Download the following certificates:
https://cacerts.digicert.com/DigiCertAssuredIDRootCA.crt.pem
https://cacerts.digicert.com/DigiCertTrustedRootG4.crt.pem
https://cacerts.digicert.com/DigiCertTrustedG4CodeSigningRSA4096SHA3842021CA1.crt.pem
- Put the certificates in a shared folder.
Install required certificates − Manually import certificates to the local certificate store
- Launch Microsoft Management Console (e.g., via Run > mmc.exe).
- Select File > Add/Remove Snap-ins.
- Select Certificates > Add.
- Select Computer account > Local computer > Finish > OK.
- Expand the Certificates (Local Computer) node in the left pane.
- Right-click Trusted Root Certification Authorities > All tasks > Import....
- Click Next > Browse to locate the certificates downloaded previously, and select the appropriate certificate.
IMPORTANT: In case the certificates are not showing in the target folder, switch the extension filter to show All files, and select the certificate.
- Select the Place all certificates in the following store option with the certificate store being Trusted Root Certification Authorities. Click Next > Finish.
- Wait for the The import was successful message to pop up.
- Repeat the steps for all certificates in all servers.
Install required certificates − GPO
- In your domain controller, launch the Group Policy Management snap-in.
- Locate an existing Group Policy Object (GPO) or create a new GPO to specify the certificate settings.
- Right-click the GPO, and click Edit.
- In the left pane, locate Computer Configuration > Policies > Windows Settings > Security Settings > Public Key Policies.
- Right-click Trusted Root Certification Authorities, and click Import....
- Click Next > Browse to locate the certificates downloaded previously, and select the appropriate certificate.
IMPORTANT: In case the certificates are not showing in the target folder, switch the extension filter to show All files, and select the certificate.
- Select the Place all certificates in the following store option with the certificate store being Trusted Root Certification Authorities. Click Next > Finish.
- Wait for the The import was successful message to pop up.
- Repeat the steps for all certificates.
TIP: Force GPO update in remote servers using the GPO Management console or scripts.