Threat Prevention Upgrade Procedure Fails When Windows Authentication Enabled
Symptom
When running Threat Prevention upgrade procedure (7.3.5.x – 7.3.9.x) and Windows Authentication is used to connect to existing Threat Prevention databases, the installation completes without errors and warnings, however, no applications were installed.
Cause
The issue occurs when the User Account Control (UAC) is enabled on the Threat Prevention console host.
Resolution
There are two options to resolve the issue:
-
Disable UAC on the Threat Prevention Console Host.
Learn more about how to disable UAC in the Microsoft article: https://learn.microsoft.com/en-us/troubleshoot/windows-server/windows-security/disable-user-account-control. Follow the instructions below:
- On the Threat Prevention console host, open Registry Editor – Start -> Run -> Regedit.
- In the Registry Editor, navigate to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System. - Double-click the EnableLUA, and verify if the value is set to
0; if not, change it to0. - Close Registry Editor and restart the computer.
-
If your company policy restricts disabling UAC then run the Threat Prevention installer
.MSIfile from admin PowerShell console and follow the normal installation procedure.